SP Racing F3 Flight Controller – Pinlayout und Anschlussplan

SP Racing F3 Flight Controller – Pinlayout und Anschlussplan
3.59 (71.76%) 17 votes

Die SP Racing F3 findet man mittlerweise auch sehr günstig bei Banggood. Dabei handelt es sich allerdings um eine Kopie.

SP Racing F3 auf Banggood (Acro und Deluxe)

SP Racing F3 auf Banggood mit integriertem OSD

SP Racing F3 Flight Controller Pinlayout

Pin IO 1 IO 2
1 GND GND
2 VCC VCC
3 CH1 / PPM CH3 / RXD
4 CH2 / GPIO CH4 / TXD
5 CH5 / GPIO CH7 / SONAR TRIGGER
6 CH6 / GPIO CH8 / SONAR ECHO
7 LED_STRIP ADC_1 / CURRENT METER
8 3.3v ADC_2 / RSSI

 

Pin SWD/DEBUG UART 1 UART 2 UART 3 I2C1
1 GND GND GND GND GND
2 NRST VCC 5v VCC 5v VCC 3,3v 5v
3 SWDIO TXD TXD/SWDCLK TXD SCL
4 SWDCLK RXD RXD RXD SDA

SP Racing F3 Flight Controller Anschluss


Diese Seite erstelle ich alleine in meiner Freizeit. Ich investiere viel Zeit und Geld, um immer qualitativ hochwertige Artikel zu verfassen. Mit einer Spende kannst du mich und den Blog aktiv unterstützen, damit ich auch in Zukunft viele weitere Artikel schreiben und neue Dinge für euch testen kann. DANKE! Phil


oder paypal[ät]seidel-philipp.de
Print Friendly

Das könnte auch interessant sein...

103 Antworten

  1. ThomasH sagt:

    Hallo
    Ich habe das Problem, dass bei 2 verschiedenen sp racing f3 im Cleanflight Menü „Motoren“ jeweils einer der Motoren nicht schneller wird. Die esc sind alle kalibriert. Habt ihr eine Idee woran das liegt.

    Thomas

    • Phil Phil sagt:

      Hey Thomas,
      Was genau meinst du? Wenn du alle Regler zusammen hoch schiebst?

      • ThomasH sagt:

        Hallo. … wenn ich an der Funke Gas gebe und dabei die Ausschläge der Motoren in Cleanflight beobachte.
        Habe am Wochenende andere ESC’s getestet ….. mit dem gleichen Ergebnis.

        • Stefan sagt:

          Hallo, genau das gleiche Problem hab ich auch Phil.
          Ich muß die Motoren fast jedes mal neu in Cleanflight kalibrieren , wenn der Akku ab war als würde die Einstellung nicht gespeichert werden.

          Stefan

  2. Tim sagt:

    Hallo zusammen,

    ich habe ein sehr „komisches“ Problem.
    Ich habe ein OSD (MW_OSD) auf Betaflight konfiguriert. Dieses läuft auch über UART 1, ABER nur wenn zusätzlich ich eine Verbindung über USB-> PC herstelle.
    Hat jemand eine Idee?

    • Phil Phil sagt:

      Hey Tim,
      kannst du das OSD mal an einen anderen UART anschließen? Denn eigentlich sollte es genau anders herum sein. OSD läuft nicht, wenn usb dran ist, denn der ist normalerweise auf UART 1

      Gruß,
      Phil

  3. Daniel Szewczyk sagt:

    Hallo
    Ich habe an dem buzzer Anschluss dauerspannung. Egal ob ich den schalte oder nicht. Er lief vorher ohne Probleme. Ich hatte aber gelesen das wenn ich statt das buzzer + vom Board den vcc+ für den Piepser nehme er dann lauter ist. Hatte es versucht aber wieder normal angeschlossen. Seitdem piepst er aber ununterbrochen. Der aux channel schaltet aber ganz normal. Was kann ich tun?

  4. OneProdigy sagt:

    Hi, Phil.

    Ich verwende in meinem Quad den Sp Racing F3 FC (die normale Version, nicht die Acro/Deluxe Variante.
    Außerdem sind T-Motor F60 Motoren und DShot fähige ESC’s (Racebee 30A BlHeli_S) verbaut.
    So viel erst mal zur vorhandenen Hardware.

    Wie du dir bestimmt schon denken kannst, möchte ich DShot nun auch verwenden, bin aber nicht sicher ob mein FC dies überhaupt unterstützt.

    Kannst Du hier eine Aussage treffen?
    Herzlichen Dank im voraus!

    • reptil1990 sagt:

      Mit Betaflight 3.1 müsste das gehen. Auf den SP3 kann auch Betaflight geflasht werden. Da gibt es die DShot Unterstützung 🙂

  5. Stefan W. sagt:

    Hallo Phil,
    ich hab langer Pause mich wieder mal an den Controller gewagt aber etwas anders angeschlossen als in deiner Darstellung oben.
    Läuft mit meiner DX6I in CF.
    Jetzt würde ich nur gerne auch die Flugmodi über einen Schalter einstellen , nur hab an meiner DX keinen 3-fach Schalter . Geht das auch über 2 Schalter Kanal 5 und 6?
    Wenn du oder jemand anders da Erfahrung hat wäre ich sehr dankbar.

    Gruß
    Stefan

    • Phil Phil sagt:

      Hey Stefan,

      kenne deine Funke nicht, aber das kannst du über einen Schalter realisieren, allerdings dann nur zwei Flugmodi.

      Schalter 1:
      Schalterpos 1: Arming ein
      Schalterpos 2: Arming aus

      Schalter 2:
      Schalterpos 1: Angle
      Schalterpos 2: Horizon

      Wenn du noch Acro dazu haben möchtest,kannst du das über den Drehpoti machen und ihm 3 Werte zuweisen in Cleanfligth

      Poti
      Wert 1: 1000 = Angle
      Wert 2: 1500 = Horizon
      Wert 3: 2000 = Acro (kein Modus)

      Damit kannst du vor dem Start die Flugmodis schalten, allerdings wird das im FPV Flug zu schwierig sein, denke ich!

      Gruß,
      Phil

      • Stefan sagt:

        Vielen Dank Phil,
        ich mach noch keinen FPV Flug , bin ja erst ganz am Anfang. Erstmal ein Gefühl dafür bekommen mit der ganzen Steuerung und dann geh ich zum FPV über. Ist auch Kostensache. FPV , wenn man richtig kaufen möchte, ist ja nicht so billig, ode gibt es schon recht gute günstige Sachen?

        • Stefan W. sagt:

          Habs mit 2 Schaltern hinbekommen, Flaps und Gear.
          Kann in der Wohnung nur nicht ganz die Unterschiede testen. Muss dann erst auf besseres Wetter warten.

          Gruß
          Stefan

  6. Stefan sagt:

    Kann man bei dem controller auch die pid werte über die fernsteuerung verändern?weiss jemand wo es dazu infos gibt?

  7. Marcus sagt:

    Hallo, dein Handbuch zu Cleanflight ist wirklich sehr hilfreich. Eine Frage hätte ich aber. Welche Baudrate muss ich denn beim SP Racing F3 Flight Controller angeben? Bzw wo oder wie komme ich an diesen Wert? Vielen Dank!

    • Phil Phil sagt:

      Hallo Marcus,
      sorry für die späte Antwort.
      Eigentlich musst du immer die Baudrate 115200 benutzten.
      Wenn das flashen nicht klappt, kannst du aber auch die manuelle Baudrate 256000 einstellen.

      Gruß,
      Phil

  8. Jannis sagt:

    Hallo Phil,

    ich und ein Kumpel haben uns einen LHI PRO Racing f3 bei amazon gekauft. In den Foren steht, dass es ein Clon der Sp Racing f3 ist ( sieht optisch auch genau so aus). Also wir wollten den ganz normal Flashen, so wie es in so vielen erklärvideos beschrieben ist. Aber weder der PC erkennt den fc, noch das Flashen klappt. Ich habe den Stm32 treiber runtergeladen und installiert.. nichts passiert, Windows Gerätemanager zeigt nichts an.. Bootloader Pins gebrückt, nicht gebrückt ( sind dabei nach deriner Anleitung vorgegangen). Aber die LED sind an.. Wir verzweifeln 🙁 Bitte Hilf uns
    Gruß Jannis und Julian

    • Jannis sagt:

      Ach es kommt dazu immer die Nachricht „failed to open serial port“.
      Bei amazon stand, dass cleanflight schon drauf sei. Wir haben eigentlich gehofft ein plug and play fc zu kaufen :/

    • Phil Phil sagt:

      Hey ihr beiden.

      Wenn ihr die Flugsteuerung nur mit einem USB Kabel mitbStrom verosgt, welche LEDs leuchten?
      Wenn man dir FC über einen bestimmten Winkel kippt sollte eine zweite led angehen. Daran kann man sehen dass eine Firmware drauf ist.

      Ansonsten kann ich mir nur vorstellen, dass es am Computer liegt. Bitte mal einen anderen Rechner ausprobieren, wenn möglich.

      Gruß,
      Phil

      • Jannis sagt:

        Also: wenn wir den fc ohne brücke anschließen, dann leuchtet die blaue LED durchgängig und die Rote blinkt ununterbrochen, das heißt auch wenn wir den FC in eine bel. Richtung neigen verändert sich beim Status gar nichts. Wir haben es auch ein einem anderen Windows PC versucht. Auch nix und an einem Apple. Der MAC gibt uns bei Cleanflight noch zusätzlich die Info in dem Ladebalken: Failed to connect Bootloader oder so.. egal ob mit brücke oder ohne. Wir haben ein ähnliches Problem im Internet gefunden, dort wirt mit dem STM32 flash loader demonstrator gearbeitet .. aber da kommen wir nicht weiter, weil wir bei den Port keinen COM auswählen können.

        • Nikolai sagt:

          Das scheint auch mein Problem zu sein. Verschiedene Rechner erkennen die Hardware nicht, es blinkt nur die rote LED die entfernt vom USB Port ist.

          Nach anschließen via USB erscheint einfach kein neuer COM Port offen, ein anderer FC macht sofort den passenden Port auf.

          CF neu flashen habe ich probiert, „failed to contact bootloader“

          Irgend einer eine Idee?

      • Nikolai sagt:

        Hey Phil,

        hier gleiches Problem, nur die rote LED blinkt, es wird kein COM Port geöffnet. Andere FCs gehen, am anderen Rechner (PC) kein Erfolg, keine Hardware wird erkannt.

        Brick?

        • Weber sagt:

          Hi
          Ich bin auch neu hier 🙂
          Sehr gute Seite sie hat mir schon sehr geholfen alles TOP 🙂
          Ich habe aber leider das selbe Problem 🙁
          Alle Treiber sind Installiert aber wenn ich die SP Racing F3 mit dem PC verbinde passiert nichts :/
          Eine Blaue LED leuchtet und die Rote Blinkt.
          Im Gerätemanager passiert nichts.
          Was kann ich noch tun ? 🙁

          • Phil Phil sagt:

            Es wird in der Cleanflight/Betaflight GUI kein Comport erzeugt, wenn du sie an dem PC anschließt?

            • Nikolai sagt:

              Bei mir half letztendlich nur ein anderer Rechner. Ich weiss noch nicht woran es lag

            • Weber sagt:

              Hi Leute 🙂
              Das mit den Antworten geht ja schnell hier Top 🙂
              Habe das Problem beseitigt !
              Es lag am USB Kabel !!!
              Das Original Samsung kabel hat sofort funktioniert !
              Das HTC Kabel wollte er nicht…..keine Ahnung ob da ein Kabel weggelassen wurde oder sonst was aber auch das HTC Kabel funktioniert in Verbindung mit dem HTC Handy ohne Probleme…
              Komige Sache 😛 😀

  9. Sebastian sagt:

    Hallo Phil,

    erstmal ein Kompliment, dass du hier wirklich alles fragen kompetent beantwortest.

    Ich bin Anfänger in diesem Segment und mir stellt sich die Frage, wie der FC mit Spannung versorgt wird un mit wieviel Volt.
    Ich war am Anfang davon Ausgeganen, dass diese über die VBAT Port mit Spannung versorgt wird.

    Danke

    • Phil Phil sagt:

      Hallo Sebastian,

      Die FC bekommt ihren Strom über einen der Motorausgänge. Schau mal in dem Anschlussplan auf den ESC mit dem 5v BEC. Da kommen die 5v für die FC her. Vbat ist nur zum Messen der Spannung.

      Beste Grüße,
      Phil

  10. Marcel sagt:

    Hallo,

    Kannst du mir weiter helfen?
    Habe eine Storm srd 250 v3 drohne und möchte sie mit meiner Futaba t10j fliegen.
    Verstehe nur nicht ganz was da schon vorverdrahtet ist.
    Wäre nett wenn du dich per mail bei mir melden würdest

  11. Pascal sagt:

    Hallo Phil

    Habe da auch ein Problem mit dem SP Racing board. Kannst Du mir sagen wie ich den USB VCP erhalte im Cleanflight unter Port? So könnte ich auf UART1 einen Empfänger anschliessen. Will wenn ich UART1 als RX einschalte unter Port und UART1 auch geht das nicht wenn ich UART1 ausschalte und RX an habe ich keine USB connection mehr.
    Habe noch einen Anhang hinzugefügt.

    Hast Du auch schon Jeti Sat oder Empfänger gebunden? Weisst du wo ich den UDI anschliessen kann und was ich dann unter Port und Configuration einstellen muss.

    Telemetrie ist das auch möglich mit den Jeti Empfänger? Was müsste ich da anschliessen? Das TX zum Empfänger und alles aktivieren unter ( Configuration)?

    Vielen Dank im Voraus für deine Hilfe und Support. Habe auch schon das Web durchsucht aber kein grossen Erfolg.

    Gruss Pascal

    Anhang:

  12. Insomnia sagt:

    Hi Phil,

    Kompliment, eine super Seite. Hat mir schon einige graue Haare erspart :-).

    Ist es möglich das GPS auch an einen anderen Anschluss zu legen, außer UART 2 ?
    Mir ist dieser Port abgerissen und zum anlöten zu winzig 🙁
    Ich habe schon hin und her probiert, komme dann aber mit den Einstellungen in Cleanflight nicht mehr klar.

    Viele Grüße

    • Phil Phil sagt:

      hi,
      das freut mich.
      Klar kannst du das GPS auch woanders anschließen.
      Du kannst es hier festlegen: http://blog.seidel-philipp.de/handbuch-cleanflight-configurator-naze32/#Tab_Ports

      Gruß,
      Phil

      • Insomnia sagt:

        ha ha, wenn man denkt es läuft alles…………….

        Hi Phil,

        das GPS habe ich jetzt am UART 3 zum laufen bekommen.
        Jetzt wollte ich über UART 1 das 3DR Radio zum laufen bekommen. Die beiden Radios sind richtig eingestellt auf 57600 und funken auch fleißig hin und her (habe das im Missionplanner getestet.
        Im Cleanflight habe ich MSP aktiviert und auch die 57600 eingestellt. An USB ist nichts angeschlossen, aber die Verbindung zu Cleanflight kommt nicht zustande.
        Hast Du noch eine Idee woran es liegen könnte?

        Viele Grüße

  13. Sebastian Kornatz sagt:

    Hi phil tolle Seite und Hilfe die du hier zur Verfügung stellst. Versuche gerade anhand deiner Beschreibungen ein racer zu bauen. Nur anscheinend stell ich mich zu doof an und weiß nicht wo ich an das pcb (ls-pdb+osd) an den FC (naze Flip32+dof 10) abschließen soll vielleicht kannst du mir ein tip geben.
    Außerdem wenn ich die Kamera und den Sender am FC anschließe habe ich dann noch den osd? Bestimmt nur wenn ich das auch über den pdb laufen lasse

    • Phil Phil sagt:

      Hey Sebastian,
      Schick mir mal Links zu den Produkten, die du verbaut hast. Was genau verstehst du nicht, was du wo anschließen musst?

      Gruß,
      Phil

  14. Stefan sagt:

    Ja über WhatsApp oder Line ginge es vielleicht auch besser. Da kann man leichter Bilder schicken und man kommuniziert direkt miteinander.

  15. Stefan sagt:

    Schade , dass hier nicht weiter geschrieben wird .
    Ich hänge fest und hab keine Idee mehr.
    Wäre schön, wenn irgendjemand noch eine Idee hätte.

    Vielen Dank

    • Phil Phil sagt:

      Hey,
      ich kann leider nicht wirklich nachvollziehen woran es bei dir liegt. Wenn ich das Ding auf meinem Tisch hätte könnte ich vielleicht etwas herausfinden, über die Kommentarfunktion ist es etwas schwierig. Komm doch mal in die FPV Racer Germany Gruppe und schildere dort dein Problem.

  16. Stefan W. sagt:

    Hallo Phil,
    ich hab das gleiche Problem wie Sascha ganz oben. Ich kann nur den Aux Kanal betätigen alles andere will nicht . Ich habs mit meiner DX6i und mit meiner FF9 versucht aber ich habe überhaupt keine Idee mehr.
    Das Board ist nur am Piepsen und reagiert nicht auf meine Befehle.
    Ich habe schon ein zweites gekauft , weil ich dachte das andere wäre kaputt, aber hier ist genau das selbe Problem. In Cleanflight hab ich auf die aktuellste Firmware geflasht und auch alle Sensoren kalibriert , die Motoren lassen sich über Cleanflight auch starten aber nix über die Funke.
    Vielleicht hast da noch eine Idee.

    Vielen Dank

    Gruß

    Stefan

  17. werner sagt:

    habe meinen fc versehendlich auf mit der 13er evo
    gefllasht jet get er nicht mer im bootloder und ich kann in auch nicht mer zurück flashen hat da einer von euch eine idee

  18. Uwe sagt:

    Moin moin, hab da noch ein komplizierteres Problem. 🙁 Ich bin Anfänger und tue mich echt schwer, hauptsächlich mit der Höhe. Weis nicht wie die Jungs das hinkriegen und bevor ich noch mehr Schrott fabriziere die Frage. Ich hab so ein Fertigteil XK 350 Stunt Racer der wie ich finde brutal geht aber viel zu schnell für mich. Da Barometer wohl nicht so die Höhe stabil hällt kam mir die Idee mit Sonar. Dieser sp-racing flight controller hat doch so einen Anschluß. Geht das eine bestimmte Mindesthöhe ca, 2m einzustellen und der Copter knallt dann nicht auf den Boden? War halt so ein Gedanke da der Dji auch Sonar hat. Ich weis das sowas in nem Racer nix zu suchen hat aber für mich wäre es zum lernen einfacher. Unbekannten FC aus dem XK 350 raus und einen anderen rein und wenigstens kein Crash bauen 😉

    • Phil Phil sagt:

      Hey Uwe,

      Der XK 350 ist ja leider auch nur aus einen dünnen Plastik Gehäuse und nicht gerade perfekt fürs Racen geeignet. Ich rate dir außerdem von einem Sonar ab, denn das wird nicht zuverlässig funktionieren, wenn du schnell fliegen möchtest. Alleine weil sich der Anstellwinkel Winkel verändert wenn du schnell fliegst, verändert sich automatisch die Höhe bzw Entfernung von Boden und Sensor.

      Wenn du wirklich racen, also schnell fliegen, möchtest empfehle ich dir einen neuen Copter aufzubauen in einem stabilen Frame aus Kohlefaser und gerne mit der SP Racing F3 Steuerung. ZMR250 ist ein günstiger und solider Frame.

      Beste Grüße,
      Phil

  19. FpVhilipp sagt:

    Hallo,
    ich habe mir ein SP Racing F3 Klon auf Amazon bestellt. Dann hab ich´s an die Cleanflight app angeschlossen und CF erkennt das Board nicht. Muss ich irgendeinen Treiber installieren?

    Gruß,
    Philipp

    • Shomarr sagt:

      Hallo,bekommst du den serial port geöffnet , oder tut sich gar nichts.
      1ster Fall : eine saubere CF mit Hilfe des CF Flasher draufmachen
      2ter fall: virtual serial Treiber installieren

    • Phil Phil sagt:

      Hallo Philipp,

      Die Treiber sollte sich automatisch installieren. Ist der Comport frei? Korrekter comport ausgewählt? Wird überhaupt ein Gerät im Gerätemanager angezeigt?

      Beste Grüße,
      Phil

      • FpVhilipp sagt:

        Hi Phil,

        Erstmal vielen Dank für deine schnelle Antwort.
        Ich kann garkeinen Comport auswählen. Bei mir steht da, wenn ich das Board angeschlossen habe „Manual selection“ und ich kann auch nichts anderes auswählen. Bin ich total falsch 🙂
        Aber im Gerätemanager vom Computer wird das Board angezeigt.

        Gruß,
        Philipp

  20. Helmut sagt:

    Hallo, habe ein etwas komplizierteres Problem. Habe bei Amazon nen FC gekauft und er lief auch, bis dieser sich beim Updaten aufhing. Daraufhin Stecker gezogen und seit dem blinkte die rote LED und ein Kontakt zwischen GS und FC kam nicht mehr zustande. Das mit der LED habe ich mit einem Boot mit Hilfe von Baseflight entfernt. Nun kontaktiert der FC jedoch immer noch nicht mit der GS und ich bekomme die Krise. Was soll ich jetzt machen?

  21. Shomarr sagt:

    Hallo ich habe ein problem mit dem spektrum Spm4648 empfänger, alle kanäle springen im sekundentakt von min auf max dawzischen gibts die richtigen Werte der Funke. Failsafe wird nicht aktiv. Serial rx auf spektrum 2048 gestezt.Die normalen spektrum sateliten funktionieren einwandfrei! Hat jemand die gleiche erfahrung gemacht?oder betreibt jemand diesen empfänger erfolgreich am F3 BOARD?

  22. David sagt:

    Hi. Beim testen von Sensoren, habe ich feststellen müssen, dass Signale vom Magnetometer so gut wie keine Ausschläge in der Grafik zeigen. Ist das normal?

  23. Daniel sagt:

    Hi. Hat hier schon jemand einen X8R Empfänger mit SBUS angeschlossen? Was muss ich da beachten? Grüsse

    • Phil Phil sagt:

      Kannst du einfach per SBus anschließen und in Cleanflight den Port konfigurieren. Wird genauso angeschlossen wie CPPM und co

      • Daniel sagt:

        Hi Phil.
        Muss der dann rechts oder links rein? Ich schau grade dein Anschlussbild an. Du hast ja eine Seite mit CPPM und eine mit SBUS. Ich versuche das jetzt nochmal anzuschliessen.

  24. Tobi sagt:

    Welchen buzzer kann ich anschließen? 3.3v oder 5v? Will direkt verlöten.

  25. Walter sagt:

    Hi Sven
    Tolle Seite hast du entworfen ??ich bekomme den Beeper nicht aktiv, aufm Netzteil funktioniert er…Schalter ist aktiviert aber es klappt nicht 🙁

  26. Korbin sagt:

    hallo welche Spannung muß ich an vbat anlegen
    das die Messung funzt mfg Sven

    • Phil Phil sagt:

      Hey Sven,
      an VBAT musst du deinen 3S/4S LiPo anschließen. Dann wird die Spannung des LiPos gemessen. Oder was meinst du?

      LG,
      Phil

  27. Tobias sagt:

    Hallo Philipp,

    mal wieder eine sehr schöne Darstellung. Ich hoffe ich habe es nicht überlesen, aber wenn die Steuerung über Vbat mit Strom versorgt wird, hält sie dann 4S aus?
    Oder muss ich doch 5 V über einen Motoreingang geben?
    Wäre toll wenn du mir weiterhelfen könntest.

    Viele Grüße
    Tobias

    • Phil Phil sagt:

      Hallo Tobias,

      die Steuerung wird NICHT über VBAT mit Strom versorgt. Das ist nur zum Messen der LiPo Spannung. 5V musst du auf jeden Fall an einen Motorausgang anlegen.

      LG,
      Phil

  28. Sascha Seresse sagt:

    Hi
    Ich hätte ne Frage, da ich bislang noch nicht fündig geworden bin.
    Weiss jemand wie ich die Pitch Kontrolle eines SimpleBGC Boards mit v.2.2b2 erhalte? Ich habe die Sp F3 im Servo Modus und das Signalkabel für Pitch auf Output 1 gelegt. Nun soll ich Cleanflight die Einstellungen treffen um per Kanal 5 an meiner TX die Pitch Achse zu manipulieren. Meine RX ist eine Orange RX R615X. Eine kleine Anleitung dazu wäre echt hilfreich, habe bislang immer nur Tuts für NAZA gefunden, was mir nicht richtig weiterhilft.

    mfg

    Sascha

    • Phil Phil sagt:

      Hey Sascha,

      Wenn du den Empfänger mit PWM anschließt, könntest du einen Kanal abzweigen und direkt an das SimpleBGC gehen.
      Bin mir nicht sicher, aber vielleicht könntest du mit dem ServoTab einen Kanal durchschleifen. Anstelle des Servos schließt du das SimpleBGc an. Da bin ich mir aber nicht 100%ig sicher.

      Phil

  29. Jörg Bartsch sagt:

    Hallo zusammen,
    habe jetzt meinen Servos und den Buzzer direkt über den Empfänger angesteuert und die SC wieder auf die PINS 1 bis 4 gelegt. ( Empfänger FRsky X4 Dingsbums mit S-Bus.)
    Kameraschwenk funktioniert, Servo bleibt kühl, Buzzer piept – alles prima!

    Gruß Jörg

  30. Bungee sagt:

    Habe nach Tomeks Anweisung die Motoren auf 1-4 und die Servos auf 7 und 8. Funktioniert prima, habe iNav geflasht wegen GPS.

  31. Tomek sagt:

    Hallo Philipp,

    hatte das selbe problem wie Jörg Bartsch mit den servos.
    Servo Tilt ist aktiviert aber es tut sich nichts.
    Bis ich die Motoren mal angeschmissen habe und siehe da das servo spielte verückt.
    Habe da ein bisschen rumprobiert und festgestellt das die servos nicht wie bei der naze32 auf 1 und 2 landen sondern auf 7 und 8.
    Also wäre die Grafik im ersten Bild fehlerhaft
    Habe einen Clown liegt es vielleicht da ran.

    Beste grüße tomek

  32. Daniel Gehring sagt:

    hi ! habe mir die UART buchse für meinen ppm emfänger abgerissen !, kann ich mir das ppm signal auf einen anderen UART legen? wenn ja wie ? ach und alle pinne sind nicht abgerissen nur +-signal alles was dahinter kommt ist noch da ! fc ist die sp racing mini naze !

  33. Wilfried R. Apel sagt:

    Hallo Phil,

    Vielen Dank für diesen Blog.
    Hat mir sehr geholfen, z.b das GPS anzuschließen. Klappte auf Anhieb.
    Jetzt möchte ich noch ein 3DR Radio anschließen.
    Ist es möglich auch hierzu einen Anschlussplan zu bekommen?
    Wäre Klasse
    Gruß
    Wilfried

    • Phil Phil sagt:

      Hey Wilfried,

      das ist eigentlich ziemlich einfach. Du musst einfach nur an einen der Seriellen Schnittelle sowie 5V und GND gehen.

      Im tab Ports musst du dann die korrekte Baudrate von deinem 3DR Radio einstellen (Standard glaube ich 57600).

      Beste Grüße,
      Phil

      • Wilfried R. Apel sagt:

        Danke Phil,

        Danke für die Antwort.
        Habe am IO 2 das 3DR Radio angeschlossen. Pin 1 bis 4 mit RX und TX getauscht zum -S Racing F3. Die biden Radios sind auf 57000 Baud eingestellt. Es scheint zu funktionieren. Beide tauschen Daten aus, nur an meinem Android Tablet kommen die nicht an.
        Benutze die App EZ_GUI Groundstation.

        Denke ich muss im Cleanflight – Configurator außer Telemetry auf on noch mehr einstellen.

        Wenn es in diesen Blog passt bitte ich um weitere Hilfe.

        Viele Grüße

        Wilfried

        • Phil Phil sagt:

          Data MSP hast du aktiviert? Eventuell RX und TX vertauscht?

          Anhang:

          • Wilfried R. Apel sagt:

            Hallo Phil,

            da ich nicht wusste was Data MSP ist
            ( Google war mir auch nicht zu Hilfe gekommen ) und in der gleichen Zeile am Anfang auch noch UART 3 steht hatte ich es auch nicht eingeschaltet.
            Nun funktioniert es sehr gut.
            Nun gleich die nächste Frage: Wenn ich die Blackbox einschalten will, wie mache ich das ?
            So sieht es im Moment aus:

            Anhang:

          • Wilfried R. Apel sagt:

            Vermute das meine Frage vom 28.3. untergegangen ist und bitte nochmals um Lösung. 🙂
            Vielen Dank

            • Phil Phil sagt:

              Hallo Wilfried,

              hehe gekonnt überlesen. 😉

              Also zum nutzten der Blackbox musst du das Blackbox feature aktivieren. Entwerfe per GUI unter Setup ganz unten oder per CLI mit dem Befehl: feature BlackBox

              Danach musst du unter Ports noch den korrekten UART für das Logging auswählen. Leider weiß ich aus dem Kopf nicht, welche es bei der sp3 ist. Teste einfach alle mal durch.

              Nun kannst du dir Blackbox starten. Das geht unter den AUX Channels. Du kannst dir Blackbox zum Beispiel mit einem Schalter an und ausschalten.

              Cheers,
              Phil

            • Wilfried R. Apel sagt:

              Hallo Phil,

              danke für die Mail.
              Die Blackbox habe ich eingeschaltet. Was ich aber nicht weis, habe doch nur 3 Port’s die lt. meinem angehängtem Bild alle belegt sind.
              Bei deinem Bild sind Softserials zu sehen, was ist das ? Kommt da die Blackbox hin ?
              Sorry das ich diese Fragen stelle, bin schon Älter 🙂
              und habe bisher noch keine Ausführliche Anleitung gefunden. Deswegen bin ich für Deine Hilfe sehr dankbar.
              Gruß
              Wilfried

            • Phil Phil sagt:

              Genau, an Softserial kannst du auch etwas anschließen. Ist eine emulierte Schnittelle, eine die direkt am IC dran hängt.

  34. Arek sagt:

    hi moin,

    ich habe den SP Racing F3 Deluxe und den X8R von fr sky.

    leider kann ich im internet nicht finden wie ich mir telemetry auf die funke lade.

    bei dem billigen china plagiat geht es, da ich da direkt nen telemetry port habe. bei dem originalen nicht mehr. kann mir wer helfen?

  35. Jörg Bartsch sagt:

    hallo Phil,
    danke für die schnelle Antwort. Also Servo Tilt ist aktiviert. Das Servo läuft auch aber wird unnatürlich heiß. Hatte ich auch bei dem alten Controller.

    Eine Idee ist jetzt, die SC wieder auf die PINS 1 bis 4 zu legen und den Servo „rausnehmen“ aus dem FC. Dann vielleicht den Servo direkt über den Empfänger FRsky X4 Dingsbums mit S-Bus.
    Ich weiß aber nicht, ob S-Bus und gleichzeitig Die anderen Ausgänge belegt werden können?

    So wirklich komfortabel ist die cleanflight Software für den ungeübten Nutzer ja leider nicht – bei Sonderfunktionen…
    ich freue mich schon, wenn Du da die Servo-Seite vom Programm erläuterst, denn alle andere ist echt sehr hilfreich! Für eine Komplettbeschreibung mit Tipps und Tricks kann ich ir auch sehr gut eine Gebühr vorstellen -Falls das mal eine Option ist

    Gruß aus dm Pott

    Jörg

  36. Jörg Bartsch sagt:

    Hallo Phil,
    ein großes Kompliment zu deiner Seite! Nach 20 j. pause bin ich wieder aktiv! die Taranis habe ich jetzt ein Jahr . Einen 4Copter (250er FPV) ist im Bau. als FC habe ich SP Racing F3 Deluxe . Mein Problem, ich kriege kein Servo richtig in Betrieb (Kippfunktion Kamera). Fragen:
    1.) Beim cc3p sind beim aktivieren des Servos die Kanäle für die ESC´s auf Pin 3 -6 verschoben – ist das beim SP Racing auch der Fall (dann auf 5 – 8)?
    2.) Warum wird das Servo so heiß?
    Danke für die Hilfe im Vorfeld (neue Gruppe: Betreutes Fliegen 🙂 )

    Gruß Jörg

  37. Rüdiger sagt:

    Hallo Phil
    Der CK Racing F3 Deluxe Flight Controller ist zu mir auf dem Weg.
    Einen SP Racing F3 Flight Controller habe ich dank deines Plans schon erfolgreich verbaut .
    Jetzt bin ich über diesen Empfänger gestolpert den ich eigentlich richtig geil finde.http://www.live-hobby.de/Sender-Empfaenger/Spektrum/Spektrum-DSMX-Quad-Race-Micro-Empfaenger-SPM4648.html
    Allerdings bin ich mir nicht sicher ob ich den problemlos anschließen kann ( 3,3V) und welchen Eingang ich dazu benutzen soll .
    Vieleicht kannst du mir da ja helfen.

    Rüdiger

  38. Sascha sagt:

    Servus

    Ich habe ein Problem beim Setup meiner SP Racing F3 Deluxe in Kombination mit dem ORX R615X und meiner Turnigy 9XR Pro Funkte mit ORX Modul.
    Ich habe alle Anschlussmöglichkeiten PPM und auch PWM versucht, jedoch bekomme nur einen Ausschlag vom AUX Channel von der Funke. Throttle und Konsorten reagieren gar nicht.
    Eine Idee worans liegen könte? Habe leider keine Servos zum testen. Ich gehe jedoch von fehlerhaften Einstellungen in der Funke aus.

    mfg

    Sascha

    • Phil Phil sagt:

      Hallo Sascha,

      es liegt wahrscheinlich wirklich an deiner Funke.

      Habe das Menü deiner Turnigy 9XR Pro nicht i m Kopf, aber blätter mal die Einstellungen durch. Dort findest du eine Seit, wo man die Sticks, Potis und Schalter den einzelnen Kanälen zuordnen kann. Es müsste die Seite „Mixer“ sein.

      Beste Grüße,
      Phil

    • Thomas sagt:

      Hallo,

      Ich habe das selbe Problem mit meiner T8FG. Die Funke ist komplett zurück gesetzt und dementsprechend auf Werkseinstellung.

      Wenn mir irgendjemand helfen kann wäre ich sehr dankbar.

      Gruß Thomas

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Nie wieder etwas verpassen…

…dann abboniere mich auf Facebook.