Airbot Omnibus OmniNXT F7 Flight Controller Anschlussplan / Wiringplan

I created this high resolution connection plan for the Airbot Omnibus OmniNXT F7 FC.
You can buy it at www.flyingmachines.de

This connection plan will be constantly updated.
Please always link to the original image (3500px × 3204px, right click -> save as) so that the latest version is always displayed.

Click the image to enlarge
If you are looking for more wiring plans, go here

Airbot OmniNXT F7 Flight Controller Anschlussplan Wiringplan

Hardware used in this wiringplan

Created by Philipp Seidel
Credits: Icons by rdy_fpv , Albert K and Me 😉

Wenn dir dieser Artikel gefallen hat und du mich unterstützen möchtest, findest du hier drei Möglichkeiten. DANKE!

Auf Patreon findest du auch weitere Infos zu meiner Person und dem Blog

paypal[ät]seidel-philipp.de

24 Antworten

  1. FPV-Don sagt:

    Aloha allerseits!
    Ich hätte nochmal ne frage bezüglich des Planes oben 😉

    auf dem Plan liegt das Smartaudio UND der Receiver auf Uart1… gibts da nen trick das zu ermöglichen oder ist es fehlerhaft im plan?

  2. Sven Gruhn sagt:

    hallo hallo allerseits
    hab ein problem mit dem 32khz gyro, sobald ich ihn aktiviere macht der copter einen flip . in betaflight sind die richtungen vertauscht. kipp ich ihn nach vorne kipt er nach rechts usw . der normale gyro läuft ganz normal 🙁 hab ich irgendwas vergessen einzustellen ?

    • Phil sagt:

      Hey, ja beide Gyros haben eine unterschiedliche Ausrichtung soweit ich weiß. Wenn du den Gyro wechselst, musst du auch die Ausrichtung wieder korrekt einstellen, dann sollte er nicht mehr flippen. 🙂

    • Gunnar sagt:

      Ich habe den USB Anschluß rechts und oben, den Gyro und Beschleunigungsmesser habe ich dann auf CW270 eingestellt.

  3. FPV-Don sagt:

    Ich hab das aktuellste genommen was das Target hergibt (vermutlich 3.4 ja). Kann grad nicht mehr nachschauen , bin nun auf der Arbeit ;/.

  4. FPV-Don sagt:

    Sind die Solderbridges auf dem plan nicht falsch markiert? Wären die richtigen nicht die beiden oben rechts direkt neben dem 4in1 Socket? Und gibts irgendwo oder besteht die Möglichkeit hier ein „Guide“ zu bekommen wie man so ein Prachtstück konfiguriert, speziell die Gyro Settings (Gyro 1,2,beide? muss ich mich entscheiden oder nicht ebenso die Esc Settings für 32k rate usw , bzw worauf man im allgemeinen achten sollte.) wären hoch interessant für mich. Danke und mfG.

    • Phil sagt:

      Hey Don,

      ne, die Lötbrücke ist korrekt. Oben rechts gibts gar keine Lötbrücke. Ich aktualisiere den Anschlussplan in den kommenden Tagen, ich bin in Kontakt mit dem Herstellern zwecks korrekter Firmware. Dazu gibt’s dann auch die richtigen set gyro Befehlen! Die FC hat nur einen Gyro, und nutzt ein anderes Target mit zwei Gyros, deswegen muss man einmalig den Gyro festlegen (sehr unschön muss ich sagen)

      Ein Allgemeines Handbuch gibts natürlich auch hier im Blog.

      Betaflight Handbuch – Philipp Seidel
      https://blog.seidel-philipp.de/betaflight-handbuch/

      Beste Grüße,
      Phil

      • FPV-Don sagt:

        hmm ich hab das ding vor mir liegen und ich hab 2×2 Solder bridges und in dem beiliegenden Wireplan stehen genau die anderen ^^

      • FPV-Don sagt:

        auf dem bild hier auf der seite sieht man die sogar und dort sind sie doch auch mit „CRNT“ und „RX“ beschriftet, ganz sicher das es hier richtig beschriftet wurde? 😉

        • Phil sagt:

          Ja, es geht doch um die Lötbrücken für Spannung

          • FPV-Don sagt:

            Also entweder steh ich total auf dem Schlauch, wir reden aneinander vorbei oder auf dem Bild hier auf der Seite sind die falschen makiert… ich tendiere 100% zu letztem 😛 Schau doch bitte nochmal genau hin, du hast die Bridges von unten links auf dem bild markiert, die für CRNT und RX sind aber die beiden oben links neben dem 4in1 Socket. Ich hab mein build auch so zusammengelötet und es funktioniert ^^

            https://costruzionedroni.it/airbot-omninxt-f7-flight-controller-betaflight-osd-barometro 90 Grad CW drehen dann isses ja quasi das bild hier, und dann sinds definitiv die flaschen.

            mfg

            • Gunnar sagt:

              Hi Don,

              um mal für „Entspannung“ zu sorgen: du hast recht. In Phils Plan sind die Fotos von der Ecke falsch. Sie stellen die Brücken dar, die es erlauben auf die mittlere Reihe der Motor/Servo Anschlüsse entweder 5V oder den RX5 für Telemetrie zu legen. Die mit CRNT und RX5 beschrifteten Brücken zwischen Motor/Servo Lötlöchern und 4in1 Buchse sollten auf dem Plan dargestellt warden, den hier wird zwischen analogem Stomsensor oder RX5 für ESC-Telemetrie ausgewählt.

              Kannst du was zu meinem Gyro Kalobrierungsproblem sagen?

              Grüße,
              Gunnar.

            • Don sagt:

              Ehrm ehrlich gesagt nein, habs grad selber extra nochmal getestet… ich hab die Gyroabweichungen weder beim ICM20608 noch beim MPU-6000 wenn ich arme (weder bei 32k,16k noch bei 8k).

              Hast du mal versucht die Motoren direkt am ESC per BLheli komplett auszuschalten und dann ohne Motoren zu armen evtl stören die dein Gyro?

  5. Gunnar sagt:

    Hallo Philipp,

    ich komme immer wieder gern auf deinen Blog und finde hier wertvolle Infos zu unserem Hobby. Vielen Dank für die Arbeit, die du hier hinein steckst.

    Für so manche FC bekommt man kaum richtige Infos über die Anschlüsse, geschweige denn den inneren Aufbau. So auch für die OmniNXT F7.
    So habe ich denn auch zunächst nach dem Plan hier verdrahtet, musste aber feststellen, dass es so gar nicht geht.

    1. habe ich menen R-XSR so verdrahtet und den RX erfolgreich konfiguriert, Telemetrie über Smartport war auf keinen Fall zum Laufen zu bringen.
    Ich bin dann auf FrSky F-Port gegangen und damit hat dann beides funktioniert. Im nachhinein weiss ich jetzt, dass die Anschlüsse S.Port und SBUS beide auf UART1 gehen und das kann ja bekanntermaßen nicht fünktionieren, da ist es schon erstaunlich, dass dies hier so eingezeichnet ist.

    2. habe ich dann den Smartaudio Anschluss gesucht. Verdrahtet ist wie hier auf dem Plan. Was soll ich anderes sagen; auch hier ist der Plan völlig Banane. (Redensart 🙂
    Wie ich mit Hilfe des beiliegenden Zettels herausfand geht der S/A Anschluss ebenfalls auf UART1 (TX1), genau wie S-Port. Ein viel beschäftigter Anschluss. Kurzerhand habe ich dann meinen S-Port vom R-XSR auf TX2 gelegt und Betaflight entsprechend konfiguriert. Damit lief es dann.

    Ich möchte dir hier nur meine Erfahrungen zur Verfügung stellen, vielleicht hilft das Anderen. Wenn ich aber völlig falsch vorgegangen bin, so bitte ich um Hinweise, wie es besser geht.

    Viele Grüße,
    Gunnar.

    • Phil sagt:

      Hey Gunnar,

      vielen Dank für deinen Kommentar. Das hier war auch der letzte Anschlussplan, welchen ich erstellt habe ohne die FC in den Händen zu haben. Ich schriebe seit Wochen mit dem Hersteller Zwecks korrekter Firmware. Jetzt weiß ich wohl, dass Smartport und Smartaudio ebenfalls nicht so wie vom Hersteller berichtet angeschlossen werden kann. Ich versuche an eine FC heranzukommen und es alles selber zu testen, damit der Anschlussplan korrekt ist.

      Danke nochmal,
      Phil

      • Gunnar sagt:

        Hallo Phil,

        na zumindest hier kann ich ja auskunft geben, auch wenn ich meist nur die Probleme liefere. Und das du mit Airbot kommunizierst ist schon prima. Ich bin eigentlich ein großer Fan, seit dem ich die Wraith32 ESC’s verwendet habe. Nun habe ich diese FC zusammen mit dem Typhoon 32 V2 in ein Armattan Cameleon verbaut. Ein low ESR Kondensator fliegt auch mit. Alles nicht billig, aber auch keine Garantie zum Glücklichwerden.
        Die FC hat definitiv ein Problem mit dem Gyro ICM20608 (gyro_to_use = SECOND). Ich kalibriere den Gyro und im Konfigurator sind dann Roll und Pitch angle auf 0. Dann arme ich die Motoren und unmittelbar danach steht das Modell im Tab Einrichtung schräg. Der Roll Winkel geht so auf Werte von größer 3° und der Pitch Winkel auf einen kleineren Wert. Das macht sich auch beim Fliegen bemerkbar. Frisch kalibriert auf den Boden gestellt, gearmed und abgehoben geht das Teil im Horizon Mode sofort weg als wäre die Trimmung total daneben. Wenn ich die Motoren dann wieder disarme, ist die Fehlkalibrierung wieder weg und das Modell steht absolut gerade. Dabei ist die Fehlstellung nicht abhängig wieviel Ampere ich durch das Gerät jage, ob die Motoren im Idle drehen oder ob mehr als 50% Throttle gegeben wird (mehr habe ich mich auf dem Tisch nicht getraut). Schalte ich wieder auf den ersten Gyro um, ist der Effekt weg. Somit ist der ganze tolle 32kHz Gyro (von dem ich bisher nur bis 16/16 probiert habe) total Banane, wenn gearmed wird, dann ist die ganze Kalibrierung weg.
        Es gibt Hinweise in den Betaflight Issues und auf rcgroups.com, dass ich mit dem Problem nicht alleine bin, zumindest den gleichen Gyro auf einer der anderen Omnibusse betreffend. Ich nehme an, die NXTF7 ist noch nicht so oft gekauft worden. Wenn du mit Airbot sprichst: es gibt Leute, die direkt von Airbot eine neuere „bessere“ Gyrobox bekommen haben, die wohl das Problem löst.
        Im Moment bin ich jedenfalls etwas enttäuscht, da ich jetzt wieder mit 8/8khz untergegs sein muss.

        • Gunnar sagt:

          Nochwas, die beiden Gyros (und Accels) haben nicht die selbe Ausrichtung Während der MPU-6000 in den Einstellungen mit normal/normal angegeben werden muss sind es beim ICM cw270/cw270 (alles Betaflight 3.4.0). Finde ich doof.

          • FPV-Don sagt:

            Grad nochmal getestet, ich hab die Probleme nicht, mit keinem der beiden Gyros (32k,16k,8k getestet).
            Irgendwas scheint nach armen dein Gyro zu Stören… evtl die Motoren? Schonmal ohne getestet zu armen (weis leider nicht ob man die mit BLheli oder so deaktivieren ansonsten ablöten)?

            • Gunnar sagt:

              Hallo Don,

              jetzt wird es komisch bei mir: Ich muss nicht mal die Batterie verbinden, die FC wird nur über USB gepowert und der RX ist verbunden. Dann stelle ich den Motor Testmodus „Ich weiss was ich mache“ ein und arme, schon verschiebt sich die Kalibrierung. Weder die ESCs noch die Motoren haben Strom und trotzdem lost das Armen etwas aus. Vielleicht ist das auch ein Betaflight Problem, ich habe 3.4.0 was hast du?

            • Gunnar sagt:

              Hallo zusammen,

              ich habe noch ein Video zu dem Gyroproblem gemacht, die schrägstellung ist so gravierend, dass ich in einem Autolevel Modus nur mit entsprechendem Gegensteuern abheben kann, das Quad geht sonst schnell nach vorn weg. Die FC liegt ausgabaut auf dem Tisch, nur mit USB Stromversorgung. Wenn man mit Ton hört, dann kann man das Klicken der Armswitch hören. Ist sowas normal? Sollte ich die FC reklamieren?

              https://youtu.be/6FPP_0xM96k

              Grüße,
              G.

          • Gunnar sagt:

            Hallo Phil, hallo Don,
            zur Info, mein Händler hat mir die FC problemlos ausgetauscht und damit habe ich das Problem jetzt nicht mehr.
            Vielen Dank an n-factory.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Nie wieder etwas verpassen…

…dann abboniere mich auf Facebook oder Youtube!