Change FrSky ISRM Mode (EU/LBT & FCC) via LUA Script

 

Some customers of new FrSky remote controls have the problem that the internal module can no longer be flashed from EU to FCC and vice versa. This is noticeable because FrSky has sent out wrong ISRM versions to customers. Following complaints from some customers, FrSky has now provided a solution to the problem but wont publish it offically. I think the solution should be public, so I’m releasing it here on my blog.

What do we need

  • OpenTX 2.3.0 or higher
  • SD-Card

Step 1: install OpenTX

Frsky Taranis X-Lite change IRSM EU LBT FCC

You have to install at least OpenTX 2.3.0 on your remote!

Step 2: check ISRM Mode

Frsky Taranis X-Lite change IRSM EU LBT FCC

Now go to page 7/7 in your „Radio Settings“ and select „Modules RX / Version„. There you will find information about your ISRM module.

 

Step 3: install LUA Script

Frsky Taranis X-Lite change IRSM EU LBT FCC

Download the LUA script (isrm_mode_1.lua) and copy it to your SD card in the folder „Scripts“ -> „Tools„.

 

Step 4: run LUA Script

Frsky Taranis X-Lite change IRSM EU LBT FCC

Now go to the folder „Scripts“ -> „Tools“ and execute the LUA script (isrm_mode_1.lua). To do this, select the script and press and hold the joystick until a submenu appears. Now click on „Execute„.

 

Step 5: change ISRM Mode

Frsky Taranis X-Lite change IRSM EU LBT FCC

You can now switch back and forth with the joystick to change the mode of your ISRM module.

 

Step 6: Check it!

Frsky Taranis X-Lite change IRSM EU LBT FCC

Now check if the module has accepted the setting! Finished!

By the way: You don’t have to rebind your models!

Wenn dir dieser Artikel gefallen hat und du mich unterstützen möchtest, findest du hier drei Möglichkeiten. DANKE!

Auf Patreon findest du auch weitere Infos zu meiner Person und dem Blog

paypal[ät]seidel-philipp.de

Print Friendly, PDF & Email

8 Antworten

  1. Frank sagt:

    The error you get on a Horus X10S is: „attempt to call field ‚drawScreenTitle‘ (a nil value)“

  2. Robert sagt:

    Does not work with ISRM FW 1.1.3 🙁

  3. Frank sagt:

    Is there a script for the Horus?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Nie wieder etwas verpassen…

…dann abboniere mich auf Facebook oder Youtube!